Página 1 de 2 12 ÚltimoÚltimo
Resultados 1 al 20 de 38

QoS estático (Queue Tree + Mangle) para Mikrotik

Esta es una discusión para el tema QoS estático (Queue Tree + Mangle) para Mikrotik en el foro Cabinas y LAN Centers, bajo la categoría Comunidad; Redacto esta guía en favor de aquellos que hayan tenido problemas, como a mi me pasó, con lo poco de ...
Página: 1


  1. #1
    Dead Man Terra Admin
    Staff
    Avatar de Miyagui
    Fecha de ingreso
    24 abr, 03
    Ubicación
    Lima
    Mensajes
    2,704

    Predeterminado QoS estático (Queue Tree + Mangle) para Mikrotik

    Redacto esta guía en favor de aquellos que hayan tenido problemas, como a mi me pasó, con lo poco de información que se tiene en la web y el tacto intermedio del procedimiento.
    No hago configuraciones. Simplemente escribí esa guía para entusiastas que deseen entender la idea y aplicarla.

    Si bien mi configuración no es la óptima, estoy escribiendo el manual de una forma más generalizada, para aquellos usuarios que tengan necesidades más avanzadas. La guía consta de 2 partes, ésta tratará de explicar el QoS básico que comúnmente se podrá usar. La segunda parte tratará sobre PCQ y un QoS dinámico, para los que manejen grandes cantidades de usuarios.

    Comenzaré con unos términos básicos y lo que utilizaremos para este tipo de QoS, debido a que en esta parte expondré los beneficios de cada opción por sobre otras distintas, comúnmente usadas, si es que se da el caso.

    Utilizaremos:

    Queue Tree: Utilizaremos Queue Tree por sobre Simple Queue debido en gran parte a la organización jerárquica que da el routerOS en este último. El problema más grande de usar Simple Queue es que debido a este tipo de organización, en caso se tenga una gran cantidad de reglas, éstas se irán cumpliendo una por una en el orden que se tiene configurado.



    Como se muestra en la siguiente imagen: La jerarquía se va cumpliendo de arriba para abajo en ese orden, en caso tengamos 100 reglas en el Simple Queue, éste utilizará recursos y tiempo para llegar a la centésima regla ya que se hace en ese orden.
    En cambio, el uso de Queue Tree todo el control de tráfico es simultáneo y especialmente da la posibilidad de usar los HTB (Heriarchical Token Bucket) que en el caso del routerOS se soportan 3 tipos: global-in, global-out y global-total.
    Global-in, todo el tráfico ingresante al router.
    Global-out, todo el tráfico saliente del router.
    Global-total, todo el tráfico.

    FW/Mangle: Aplicaremos reglas por cada tipo de conexión utilizando puertos comunes, marcándolas para poder procesarlas luego en nuestro Queue Tree.

    Cadena Prerouting: Utilizaremos Prerouting en este caso, pero también es posible utilizar Forward en el Mangle. Esta vez, utilizaremos prerouting (Rojo) debido a que para la siguiente parte de la guía, ya que según el orden del flujo del QoS, este se aplicará un paso pal de Forward lo cual en la siguiente guía utilizaremos para un QoS basado en PCQ (Verde).

    Mark Connection: Utilizaremos mark connection para de esta forma poder monitorear los IPs a los que nos estamos conectando y especialmente para agregar modificadores especiales POR conexión, como el tamaño de la conexión o de paquetes, para luego marcar dichas conexiones con el Mark Packet.

    Mark Packet: Utilizaremos mark packet para poder trabajar con las conexiones marcadas en el Queue Tree.



    Guía de aplicación

    Comenzaremos entonces creando las conecciones y sus respectivos Packet Marks en el Mangle

    Dentro del Winbox Ingresamos a IP > Firewall > Pestaña Mangle > [+]



    Procedemos con la identificación del puerto (revisar siguiente post) con los puertos comúnmente usados, (en contínua actualización).

    Como ejemplo utilizaré el puerto 80 que es el usado para todo el tráfico de la Web y con unos modificadores extras para diferenciar web browsing (500kbytes o menos) de las descargas (500kbytes o más).

    En la ventana de New Mangle Rule, pestaña General:
    Chain seleccionamos Prerouting Ya explicado arriba
    Protocol seleccionamos 6 (TCP). Se puede usar 17 (UDP) también, dependiendo de lo que queramos marcar. En este caso TCP es lo que va al caso
    Dst Port seleccionamos el puerto al que la marca apuntara en este caso: 80



    En la misma ventana, pero pestaña Advanced
    Connection Bytes seleccionaremos el rango del tamaño de archivo: 0-512000 eso quiere decir que como máximo las conexiones con 512kb van a ser marcadas para esta regla. Luego optaremos en marcar las conexiones de más de 512kb pero con otra marca (descarga)



    En la misma ventana, pero pestaña ]Action
    Action seleccionaremos mark connection
    New Connection Mark seleccionaremos un nombre que identifique esta conexión de menos de 512kb por ejemplo: http_conn
    Passthrough, Check activado



    Para terminar con nuestra primera regla de marca le dejamos un comentario para saber a donde apunta, en este caso un simple HTTP basta.



    Luego para finalizar le damos a Apply y luego Ok


    Ahora pasaremos a marcar el paquete de la conexión que acabamos de marcar para tener acceso a este a través del Queue Tree.

    Empezamos dándole nuevamente a [+]

    En la ventana New Mangle Rule, pestaña General:
    Chain seleccionamos Prerouting
    Connection Mark seleccionamos la conexión antes marcada: http_conn



    En la misma ventana, pestaña Action
    Action seleccionamos Mark Packet
    New Packet Mark seleccionamos un nombre distintivo para este paquete por ejem: http
    Passthrough en este caso le quitamos el check porque el trafico ya está siendo redirigido a través de la anterior marca y quitamos el check para evitar redundancias.



    La idea es configurar nuestras reglas con los puertos más usados (ver post siguiente)
    Para ello, tener en mente:
    Se puede escoger el protocolo ICMP (Ping), TCP o UDP, dependiendo de cual es el que está en uso.
    Se pueden escoger más que un solo puerto. Revisar la siguiente imagen con todos los datos que he usado yo en mi caso. Soy bastante quisquilloso en lo que refiere a juegos por lo que manualmente he agregado los puertos que estos utilizan para darles una prioridad mayor que a las demás. Definitivamente se puede englobar todo dentro de uno solo, pero para fines educativos los puse separados.



    Para finalizar está parte cabe recalcar la última regla Otras Conexiones
    Si alguna conexión no llega a marcarse en ninguna de las reglas anteriores creamos como regla FINAL una que englobe lo que queda del tráfico.

    Para ello crearemos una nueva regla con Chain: Prerouting y en Action: Mark Connection con passthrough activado.



    Como antes, con cualquier otra regla. Creamos una nueva para marcar el paquete: Prerouting, Connection Mark apuntando a la marca de conexión del anterior paso y Mark Packet sin passthrough como en la imagen:




    Para los que le gusta todo fácil, acá el código de mi mangle. Solo pegarlo en un Nuevo Terminal

    Código:
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="ICMP (Ping)" disabled=no new-connection-mark=icmp_conn passthrough=yes protocol=icmp
    add action=mark-packet chain=prerouting comment="" connection-mark=icmp_conn disabled=no new-packet-mark=icmp passthrough=no
    add action=mark-connection chain=prerouting comment=DNS disabled=no dst-port=53 new-connection-mark=dns_conn passthrough=yes protocol=udp
    add action=mark-packet chain=prerouting comment="" connection-mark=dns_conn disabled=no new-packet-mark=dns passthrough=no
    add action=mark-connection chain=prerouting comment=Http connection-bytes=0-500000 disabled=no dst-port=80 new-connection-mark=http_conn passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=http_conn disabled=no new-packet-mark=http passthrough=no
    add action=mark-connection chain=prerouting comment="Http Descarga" connection-bytes=500000-5000000 disabled=no dst-port=80 new-connection-mark=http_conn_descarga passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=http_conn_descarga disabled=no new-packet-mark=http_descarga passthrough=no
    add action=mark-connection chain=prerouting comment=Https disabled=no dst-port=443 new-connection-mark=https_conn passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=https_conn disabled=no new-packet-mark=https passthrough=no
    add action=mark-connection chain=prerouting comment=WoW disabled=no dst-port=3724,6112-6114,6881-6999 new-connection-mark=wow_conn passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=wow_conn disabled=no new-packet-mark=wow passthrough=no
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=3724 new-connection-mark=wow_udp_conn passthrough=yes protocol=udp
    add action=mark-packet chain=prerouting comment="" connection-mark=wow_udp_conn disabled=no new-packet-mark=wow_udp passthrough=no
    add action=mark-connection chain=prerouting comment=LoL disabled=no dst-port=2099,5222,5223,8393-8400 new-connection-mark=lol_conn passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=lol_conn disabled=no new-packet-mark=lol passthrough=no
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=5000-5500 new-connection-mark=lol_udp_conn passthrough=yes protocol=udp
    add action=mark-packet chain=prerouting comment="" connection-mark=lol_udp_conn disabled=no new-packet-mark=lol_udp passthrough=no
    add action=mark-connection chain=prerouting comment=Ventrilo disabled=no dst-port=30572 new-connection-mark=vent_conn passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=vent_conn disabled=no new-packet-mark=ventrilo passthrough=no
    add action=mark-connection chain=prerouting comment=MSN disabled=no dst-port=1863 new-connection-mark=msn_conn passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=msn_conn disabled=no new-packet-mark=msn passthrough=no
    add action=mark-connection chain=prerouting comment=Winbox disabled=no dst-port=8291 new-connection-mark=winbox_conn passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=winbox_conn disabled=no new-packet-mark=winbox passthrough=no
    add action=mark-connection chain=prerouting comment="Dragon Nest" disabled=no dst-port=14300,14301,14403,7000,14500 new-connection-mark=dragon_nest_conn passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=dragon_nest_conn disabled=no new-packet-mark=dragon_nest passthrough=no
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=15100-15110 new-connection-mark=dragon_nest_udp_conn passthrough=yes protocol=udp
    add action=mark-packet chain=prerouting comment="" connection-mark=dragon_nest_udp_conn disabled=no new-packet-mark=dragon_nest_udp passthrough=no
    add action=mark-connection chain=prerouting comment=Otros disabled=no new-connection-mark=otras_conn passthrough=yes
    add action=mark-packet chain=prerouting comment="" connection-mark=otras_conn disabled=no new-packet-mark=other passthrough=no
    ----------------------------------------------------------------------------------------------------------------------------

    Ahora lo que queda es ir al Queue Tree para así escoger los límites y prioridades de las distintas conexiones.

    Para esto comenzamos por:

    Entrar Queues > Queue Tree > [+]

    Lo que se hará primero es crear una nueva cola (Queue), como Padre (Parent) de las subsiguientes solamente para tener un orden y se haga más fácil las limitaciones. Utilizaremos 2: una de descarga y una de subida.

    La cola padre de descarga la configuraremos de la manera siguiente, donde el Parent de esta cola es el Puerto FÍSICO del que sale toda nuestra información del router (Osea el puerto LAN).



    La siguiente cola que crearemos la configuraremos de la misma manera, solo que el Parent nuevo es el creamos en el paso anterior, pero dirigido a la conexión que marcamos en el Mangle. Hacemos uno por cada Conexión marcada en el Mangle inclusive la que engloba todas. En mi caso hice nuevas subdivisiones extra, esto depende del uso de cada persona. Por otro lado, se tiene que ingresar la prioridad que tendrá cada conexión, como en mi caso priorizo juegos por sobre todo lo demás, le he dado más prioridad que http, pero no menos prioridad que los VoIP.



    Al finalizar con todas las colas deberían tener algo parecido al mio:



    Para copy/paste sobre el terminal OJO modificar "LAN ether5" con el puerto de salida que estén usando y WAN por el de entrada (el puerto conectado a su router con modo bridge).
    Código:
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=QoS_down parent="LAN ether5" priority=1
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=2M max-limit=2350k name=3QoS_down_Web parent=QoS_down priority=5
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=2QoS_down_Games parent=QoS_down priority=2
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=1QoS_down_VoIP parent=QoS_down priority=1
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=QoS_up parent=WAN priority=1
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=1QoS_up_VoIP parent=QoS_up priority=1
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=2QoS_up_Games parent=QoS_up priority=2
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=400k max-limit=512k name=3QoS_up_Web parent=QoS_up priority=5
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name="ICMP_(Ping)_up" packet-mark=icmp parent=1QoS_up_VoIP priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=DNS_up packet-mark=dns parent=3QoS_up_Web priority=5 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=Http_up packet-mark=http parent=3QoS_up_Web priority=5 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=Https_up packet-mark=https parent=3QoS_up_Web priority=5 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=Otros_up packet-mark=other parent=3QoS_up_Web priority=6 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=WinBox packet-mark=winbox parent=1QoS_down_VoIP priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=MSN packet-mark=msn parent=3QoS_down_Web priority=5 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=LoL_udp packet-mark=lol_udp parent=2QoS_down_Games priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=Ventrilo_up packet-mark=ventrilo parent=1QoS_up_VoIP priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=WinBox_up packet-mark=winbox parent=1QoS_up_VoIP priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name="Dragon Nest" packet-mark=dragon_nest parent=2QoS_down_Games priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=MSN_up packet-mark=msn parent=3QoS_up_Web priority=5 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name="Dragon Nest_up" packet-mark=dragon_nest parent=2QoS_up_Games priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name="Dragon Nest_udp" packet-mark=dragon_nest_udp parent=2QoS_down_Games priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name="Dragon Nest_udp_up" packet-mark=dragon_nest_udp parent=2QoS_up_Games priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=LoL_up packet-mark=lol parent=2QoS_up_Games priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=LoL_udp_up packet-mark=lol_udp parent=2QoS_up_Games priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=WoW_up packet-mark=wow parent=2QoS_up_Games priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=WoW_udp_up packet-mark=wow_udp parent=2QoS_up_Games priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=Http_Descarga packet-mark=http_descarga parent=3QoS_down_Web priority=6 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name="ICMP_(Ping)" packet-mark=icmp parent=1QoS_down_VoIP priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=DNS packet-mark=dns parent=3QoS_down_Web priority=5 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=Http packet-mark=http parent=3QoS_down_Web priority=5 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=Https packet-mark=https parent=3QoS_down_Web priority=5 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=WoW packet-mark=wow parent=2QoS_down_Games priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=WoW_udp packet-mark=wow_udp parent=2QoS_down_Games priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=LoL packet-mark=lol parent=2QoS_down_Games priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=Ventrilo packet-mark=ventrilo parent=1QoS_down_VoIP priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=Otros packet-mark=other parent=3QoS_down_Web priority=7 queue=default
    Nótese que la única limitación que use fue a la web y todo lo restante lo he dejado para juegos.
    Nótese que el Parent de QoS_up es WAN en vez de Ether5
    Esta última parte la hice más ínfima, la continuaré más tarde que ya estoy de salida.
    Está sujeta a modificaciones, en caso me haya equivocado en algo favor de avisar para editarlo.



    -- En continua actualización--

    Basado en el diseño QoS por Megis en el MUM 09 en EEUU: http://mum.mikrotik.com/presentation.../megis_qos.pdf
    Última edición por Miyagui; 23/02/2012 a las 11:31




  2. #2
    Dead Man Terra Admin
    Staff
    Avatar de Miyagui
    Fecha de ingreso
    24 abr, 03
    Ubicación
    Lima
    Mensajes
    2,704

    Predeterminado Re: QoS estático (Queue Tree + Mangle)

    Puertos frecuentes:



    Para la edición de esta tabla, agradecería me den los puertos que se deseen agregar, PS3 o XboX360, etc
    Última edición por Miyagui; 02/09/2011 a las 16:14


  3. #3
    Dead Man Terra Admin
    Staff
    Avatar de Miyagui
    Fecha de ingreso
    24 abr, 03
    Ubicación
    Lima
    Mensajes
    2,704

    Predeterminado Re: QoS estático (Queue Tree + Mangle)

    Prueba de que funciona:



    Para aquellos ajenos al significado real de Latency o Packet Loss.
    Latency es cuando los paquetes están en cola y la demora de esos paquetes en cola se traduce como Latency. Si otra conexión está copando la línea los paquetes que necesitamos para nuestros juegos estarán en cola. Con este tipo de QoS pasarán a la cola los paquetes de nuestra descarga en vez de la de nuestros juegos. Loss por otro lado, es cuando estos paquetes se caen porque nunca encuentran tiempo para pasar de la cola a la conexión.

    Los packets en cola son los mostrados en la imagen, mientras que Dragon Nest (un juego) no tiene paquetes en cola.
    Última edición por Miyagui; 02/09/2011 a las 15:36


  4. #4
    Senior Member Avatar de sstuloboss
    Fecha de ingreso
    14 mar, 09
    Mensajes
    337

    Predeterminado Re: QoS estático (Queue Tree + Mangle)

    gracias miyagui de daniel san
    :P CREE EN UN DIOS GRANDE Y VERAZ UN DIOS GRANDE , A JESUS EL SEÑOR SOBRE TODO

  5. #5
    Dead Man Terra Admin
    Staff
    Avatar de Miyagui
    Fecha de ingreso
    24 abr, 03
    Ubicación
    Lima
    Mensajes
    2,704

    Predeterminado Re: QoS estático (Queue Tree + Mangle)

    Agregados scripts para aplicar directamente a un Nuevo Terminal.
    Para el segundo modificar "LAN ether5" con el puerto de salida que estén usando y WAN por el de entrada (el puerto conectado a su router con modo bridge).

    Salu2


  6. #6
    Senior Member Avatar de 4rc4nh3ll
    Fecha de ingreso
    09 dic, 09
    Mensajes
    97

    Predeterminado Re: QoS estático (Queue Tree + Mangle) para Mikrotik

    Muy bueno Miyagui, de aqui hasta la certificacion jaja.

    Con esto el nivel de los LAN va aumentar, animense todos que no es tan caro y como les dije en Pentimun III para pruebas tambien les sale.

    P.D. upss me salio doble, lo siento.

  7. #7
    Senior Member
    Fecha de ingreso
    22 nov, 10
    Mensajes
    52

    Predeterminado Re: QoS estático (Queue Tree + Mangle) para Mikrotik

    Gracias , es cierto creo que los administradores quienes quieran mejorar en sus servicios y hacerle ver al cliente que siempre se quiere dar lo mejor ..!!!

    consulta hay un lugar donde se dicten clases se ve interesante sinceramente espero logar el objetivo de abrir el negocio..

  8. #8
    Member
    Fecha de ingreso
    02 nov, 10
    Mensajes
    35

    Predeterminado Re: QoS estático (Queue Tree + Mangle) para Mikrotik

    Gracias Muy buen aporte lo voy a probar en caso de que sea directo y por bridge en que cambia al configuracion y si no tienes por ahi alguno de balanceo de carga para 2 o 3 lineas nuevemente gracias x el dato saludos

  9. #9
    h4x0r Administrador Avatar de Devil
    Fecha de ingreso
    24 may, 01
    Ubicación
    Peru
    Mensajes
    8,673

    Predeterminado Re: QoS estático (Queue Tree + Mangle) para Mikrotik

    Excelente aporte Miyagui. Recien me di el tiempo de leer todo el tutorial. Solo una sugerencia. Por seguridad no recomendaria darle tanta prioridad al ping. Si alguien quiere joder con un ping flood, te tumba. Claro, no es muy comun, a veces pasa, especialmente si paras en IRC. En todo caso recomendaria bloquear algunos tipos de ICMP y solo dejar los estrictamente necesarios.
    Devil: Sandro Jurado
    Admin: Bloodzone.net / Gamers4Life
    Bloodzone.net: Reglas | Netiqueta | CS 1.6 FAQ | HLDS howto
    Specs: Intel Core i7 3770K |
    Gigabyte Z77X-UD5H | Kingston HyperX 16GB PC3-15000 | Zotac GTX670 | Corsair Neutron GTX 240GB SSD + 3TB HDD | ASUS Xonar Essence ST | Seasonic Platinum 1000W | Razer Mamba 4G | Razer BlackWidow Ultimate | Sennheiser PC 360 | BenQ XL2410T 120Hz
    Otros: Twitter Facebook Youtube Twitch.tv

  10. #10
    Dead Man Terra Admin
    Staff
    Avatar de Miyagui
    Fecha de ingreso
    24 abr, 03
    Ubicación
    Lima
    Mensajes
    2,704

    Predeterminado Re: QoS estático (Queue Tree + Mangle) para Mikrotik

    Cita Iniciado por TristanX Ver mensaje
    Gracias Muy buen aporte lo voy a probar en caso de que sea directo y por bridge en que cambia al configuracion y si no tienes por ahi alguno de balanceo de carga para 2 o 3 lineas nuevemente gracias x el dato saludos
    Me gustaría hacer uno de balanceo, pero no tengo 2 líneas para probarlo. Voy a ver si luego me animo. Sino revisa el foro de ryohnosuke, tiene muy buenas guías sobre estos temas.

    Sobre lo del ping, más que nada lo puse arriba para poder tener un ping real para hacer pruebas. Debe haber una forma de limitarlo o simplemente crear una regla que avise en caso haya un flood.

    Por otro lado, me faltó recalcar que si bien yo hice una regla por cada puerto, es posible simplemente dejarlo en la regla Otros y a esta darle prioridad mayor que la del puerto 80.

    Salu2


  11. #11
    h4x0r Administrador Avatar de Devil
    Fecha de ingreso
    24 may, 01
    Ubicación
    Peru
    Mensajes
    8,673

    Predeterminado Re: QoS estático (Queue Tree + Mangle) para Mikrotik

    Tambien puedes añadir esto:

    http://wiki.mikrotik.com/wiki/Manual:IP/Firewall/Filter

    al final de la pagina estan las reglas para el packet filter de ICMP. La idea es solo filtrar los tipos innecesarios y dejar pasar lo util.
    Devil: Sandro Jurado
    Admin: Bloodzone.net / Gamers4Life
    Bloodzone.net: Reglas | Netiqueta | CS 1.6 FAQ | HLDS howto
    Specs: Intel Core i7 3770K |
    Gigabyte Z77X-UD5H | Kingston HyperX 16GB PC3-15000 | Zotac GTX670 | Corsair Neutron GTX 240GB SSD + 3TB HDD | ASUS Xonar Essence ST | Seasonic Platinum 1000W | Razer Mamba 4G | Razer BlackWidow Ultimate | Sennheiser PC 360 | BenQ XL2410T 120Hz
    Otros: Twitter Facebook Youtube Twitch.tv

  12. #12
    Senior Member Avatar de ryohnosuke
    Fecha de ingreso
    09 dic, 03
    Mensajes
    1,051

    Predeterminado Re: QoS estático (Queue Tree + Mangle) para Mikrotik

    Anda, mira que creí que tenía la exclusiva, ahora seguro google me va odiar. xD

    En el otro lado dejé algunos consejos para mejorar un toque tu QoS.

    Saludos
    ccc

  13. #13
    Junior Member
    Fecha de ingreso
    10 jul, 11
    Mensajes
    2

    Predeterminado Re: QoS estático (Queue Tree + Mangle) para Mikrotik

    claro pero como lo arreglas para las descarga saludos

    pd: ryo tienes como 1000 post no me digas q eres moredador aqui jjjejejjj

  14. #14
    Banned
    Fecha de ingreso
    04 abr, 09
    Mensajes
    113

    Predeterminado Re: QoS estático (Queue Tree + Mangle) para Mikrotik

    Miyagui gracias por la guía pero yo tengo una pregunta bastante concreta

    de mi linea de 2mb que tengo algo de 200kb/s.

    con mikrotik puedo usar digamos 160kb/s en videos de youtube.

    y jugar con los 40kb/s restantes? juegos que no consuman mucho ancho de banda, sin que se lagee el juego?


    es que yo tengo instalado el netlimiter en mi pc, y por mas que limite la velocidad de descarga/youtube a 100kb/s los juegos se lagean.. tengo que limitar hasta 50kb/s para no sentir lag. osea tengo que tener disponibles 150kb/s para JUGAR?

    no le encuentro coherencia y queria saber si con mikrotik si puedo usar esos 200kb/s mientras juego.

  15. #15
    Dead Man Terra Admin
    Staff
    Avatar de Miyagui
    Fecha de ingreso
    24 abr, 03
    Ubicación
    Lima
    Mensajes
    2,704

    Predeterminado Re: QoS estático (Queue Tree + Mangle) para Mikrotik

    Yo usaba netlimiter y tenía el mismo problema. 3mb limitado a 250kbps e igual lageaba. Con este QoS ya ando tranquilo desde que lo instalé. Con los mismos datos que has dejado debería funcionar tranquilamente, sería cosa de probar nomás.

    Salu2


  16. #16
    Junior Member
    Fecha de ingreso
    01 mar, 09
    Mensajes
    1

    Predeterminado Re: QoS estático (Queue Tree + Mangle) para Mikrotik

    Buen dia devil, soy administrador de una cabina pensando en mejorar el servicio y agradecido de esta bendita pagina que nos ayuda muchisimo a los qu eestamso en este negicio, queria consultarte donde encuentro el mikrotik y quien hace la configuracion, tengo dos lineas. espeor tu respuesta gracias.

  17. #17
    Junior Member
    Fecha de ingreso
    23 nov, 09
    Ubicación
    Los Olivos
    Mensajes
    4

    Predeterminado Re: QoS estático (Queue Tree + Mangle) para Mikrotik

    hola a todos ...

    interesante todo lo que este equipo puede hacer....
    que modelos me recomiendan adquirir? costo aprox ?
    .. hace balanceo de enlaces y adm. de ancho de banda????
    Saludos!!!
    Fred

  18. #18
    Junior Member
    Fecha de ingreso
    10 oct, 11
    Mensajes
    2

    Predeterminado Re: QoS estático (Queue Tree + Mangle) para Mikrotik

    Amigos,definitivamente no funciona la limitación de "Http Descarga", haga las modificaciones que haga siempre se me muestra TAL como en la IMAGEN del Queue tree que se muestra arriba ( osea, no marca nada)

    pregunto,
    Si marcamamos la conexion de la navegacion con 0-500000 bytes, la descarga por el puerto 80 no debería ser 500000-0 ? osea todo el resto que pasa por el puerto 80 ?
    pero igual, no funciona...
    entonces... NO SERA que se tiene que MARCAR passthrough en YES donde se le coloca ahi donde se marca el paquete http ?
    porque actualmente esta en NO, lo que saca al paquete del mangle... y jamás llegaria a ser marcado o reconocido como descarga...


    add action=mark-connection chain=prerouting comment=Http connection-bytes=0-500000 disabled=no dst-port=80 new-connection-mark=http_conn passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=http_conn disabled=no new-packet-mark=http passthrough=no
    add action=mark-connection chain=prerouting comment="Http Descarga" connection-bytes=500000-5000000 disabled=no dst-port=80 new-connection-mark=http_conn_descarga passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=http_conn_descarga disabled=no new-packet-mark=http_descarga passthrough=no
    Saludos.

  19. #19
    Dead Man Terra Admin
    Staff
    Avatar de Miyagui
    Fecha de ingreso
    24 abr, 03
    Ubicación
    Lima
    Mensajes
    2,704

    Predeterminado Re: QoS estático (Queue Tree + Mangle) para Mikrotik

    Sobre lo primero:

    Código:
    connection-bytes=500000-5000000
    Si tienes razón, pensé que puse una línea más usando los archivos de más de 5mb para otra marca.

    Sobre lo segundo, no se puede tener al passthrough en YES en ese caso debido a que se crearía una redundancia con la conexión que si está pasando y está siendo marcada también.

    Recuerda de que tienes que tener tu mikrotik bien configurado para que el QoS reconozca la conexión entrante.
    Si puedes postea tu queue tree.

    Salu2


  20. #20
    Member
    Fecha de ingreso
    02 nov, 10
    Mensajes
    35

    Predeterminado Re: QoS estático (Queue Tree + Mangle) para Mikrotik

    A ver si te das un tiempo y ayudas con un buen balanceo gracias

Página 1 de 2 12 ÚltimoÚltimo

LinkBacks (?)

  1. 24/10/2014, 12:50
  2. 07/10/2014, 00:55
  3. 22/04/2014, 17:31
  4. 11/04/2014, 12:53
  5. 26/02/2014, 21:38
  6. 16/02/2014, 12:12
  7. 03/11/2013, 07:24
  8. 15/10/2013, 16:34
  9. 13/10/2013, 21:44
  10. 10/09/2013, 09:28
  11. 07/09/2013, 01:46
  12. 27/08/2013, 18:37
  13. 23/08/2013, 15:47
  14. 14/08/2013, 19:33
  15. 30/07/2013, 23:54
  16. 09/07/2013, 03:25
  17. 14/06/2013, 19:55
  18. 05/06/2013, 17:23
  19. 27/05/2013, 20:51
  20. 13/05/2013, 07:39
  21. 03/05/2013, 17:40
  22. 30/04/2013, 23:26
  23. 27/04/2013, 09:52
  24. 31/03/2013, 01:00
  25. 29/03/2013, 00:17
  26. 27/03/2013, 21:59
  27. 17/03/2013, 17:42
  28. 13/03/2013, 07:54
  29. 18/01/2013, 17:56
  30. 14/01/2013, 12:17
  31. 23/11/2012, 13:11
  32. 12/11/2012, 21:52
  33. 02/11/2012, 18:23
  34. 13/10/2012, 11:33
  35. 08/10/2012, 23:06
  36. 29/09/2012, 15:11
  37. 27/09/2012, 11:15
  38. 13/09/2012, 12:41
  39. 18/06/2012, 09:35
  40. 03/06/2012, 23:00
  41. 28/05/2012, 14:49
  42. 15/05/2012, 16:30
  43. 12/05/2012, 20:31
  44. 22/04/2012, 11:33
  45. 14/04/2012, 05:57
  46. 08/04/2012, 12:39
  47. 28/03/2012, 15:22
  48. 24/03/2012, 06:32
  49. 15/03/2012, 07:55

Temas similares

  1. One Tree Hill
    Por CoLzeR- en el foro TV
    Respuestas: 45
    Último mensaje: 03/06/2012, 21:59
  2. router Mikrotik Rb750 para lan center
    Por atila en el foro Cabinas y LAN Centers
    Respuestas: 13
    Último mensaje: 29/08/2011, 02:35
  3. QoS and Traffic Shaping
    Por ctcda6v en el foro Linux
    Respuestas: 0
    Último mensaje: 24/08/2010, 19:21
  4. Talent tree varios WOTLK
    Por sczor en el foro WoW
    Respuestas: 30
    Último mensaje: 13/08/2008, 23:23
  5. Mages talent tree - Patch 1.11
    Por Miyagui en el foro WoW
    Respuestas: 0
    Último mensaje: 05/05/2006, 11:23

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •